Forum maintenance: Nov 2020

Talk about whatever you feel like.
User avatar
Martin Blank
Knower of Things
Knower of Things
Posts: 12684
Joined: Fri Feb 07, 2003 4:11 am
Real Name: Jarrod Frates
Gender: Male
Location: Dallas, TX

Re: Forum maintenance: Nov 2020

Post by Martin Blank » Tue Dec 08, 2020 6:40 pm

For those running into 403 messages, please note the URL you were trying to reach and the date and time with time zone. I'll check the various logs and see if anything shows up. You can post them here or in PM. You can also hit me up on Facebook if you've friended me (I may answer), or on Hangouts at jfrates@gmail.com (I probably will answer, unless I'm asleep).
If I show up at your door, chances are you did something to bring me there.

User avatar
BtEO
Redshirt
Posts: 4793
Joined: Tue Feb 18, 2003 2:28 pm
Location: England

Re: Forum maintenance: Nov 2020

Post by BtEO » Fri Dec 11, 2020 6:43 pm

Just hit a 403 with this link 2020/12/11 ~18:40 GMT. I don't get them especially often though.

And a bunch more a few minutes later.

And one where the page eventually loaded but all the CSS/JavaScript was 403.
Is is possibly some kind of rate limiting thing set on too low of a threshold? I was doing my usual thing of opening the unread posts page then opening new tabs for each thread in succession. The difference being that with the higher than average new post count compared to the last few years the amount of requests was maybe enough to trip the detection?

User avatar
auntmousie
Redshirt
Posts: 92
Joined: Sun Jul 26, 2020 8:10 am
Real Name: Alyson Young
Gender: Female
Location: Portland, Oregon

Re: Forum maintenance: Nov 2020

Post by auntmousie » Fri Dec 18, 2020 8:49 am

Seannery wrote: Fri Dec 04, 2020 11:24 pm Same address.
By the way, the error page:

Code: Select all

<!DOCTYPE HTML PUBLIC "-//IETF//DTD HTML 2.0//EN">
<html><head>
<title>403 Forbidden</title>
</head><body>
<h1>Forbidden</h1>
<p>You don't have permission to access this resource.</p>
<hr>
<address>Apache Server at www.reallifeforums.com Port 443</address>
</body></html>
I got this too, on the "When did you join RLC" thread. Just that one.
When all is said and done, more is generally said than is done.
Ask me anything - no, really - but be warned: I will answer. If you didn't want to know... don't ask.

User avatar
Martin Blank
Knower of Things
Knower of Things
Posts: 12684
Joined: Fri Feb 07, 2003 4:11 am
Real Name: Jarrod Frates
Gender: Male
Location: Dallas, TX

Re: Forum maintenance: Nov 2020

Post by Martin Blank » Thu Dec 24, 2020 7:56 pm

I still can't pin down what's going on here. I did update the PHP-FPM engine, so maybe there's an accidental fix there. Still tracking this, though.
If I show up at your door, chances are you did something to bring me there.

User avatar
raptor9k
Redshirt
Posts: 1358
Joined: Tue May 15, 2007 8:33 pm
Gender: Male
Location: Arkansas

Re: Forum maintenance: Nov 2020

Post by raptor9k » Mon Jan 11, 2021 1:16 am

403 error 7:15 pm central. Url: viewtopic.php?f=3&t=28902&start=45

User avatar
Martin Blank
Knower of Things
Knower of Things
Posts: 12684
Joined: Fri Feb 07, 2003 4:11 am
Real Name: Jarrod Frates
Gender: Male
Location: Dallas, TX

Re: Forum maintenance: Nov 2020

Post by Martin Blank » Mon Mar 15, 2021 4:20 am

I still have no goddamned idea why this is happening. I've upped the logging yet again. The catch is, restarting the service fixes the issue for a bit, so even if I run across it (which I finally have a few times), I still don't get enough info, and upping the logging and restarting fixes it. :P
If I show up at your door, chances are you did something to bring me there.

User avatar
BtEO
Redshirt
Posts: 4793
Joined: Tue Feb 18, 2003 2:28 pm
Location: England

Re: Forum maintenance: Nov 2020

Post by BtEO » Mon Mar 15, 2021 9:48 pm

So my usual trick is to open 'unread posts' then open each post in a new tab, and I'd start to see the errors on maybe the second or third tab. Lately I've been trying to view posts one at a time going back to unread after each one and so far I haven't hit the error under those conditions.

This again leans into some kind of rate-limiting or concurrent connection problem.

User avatar
FirebirdNC
Mad Hatteras
Posts: 1958
Joined: Tue Feb 13, 2007 3:00 pm
Real Name: Jennifer
Gender: Female
Location: Hatteras,NC

Re: Forum maintenance: Nov 2020

Post by FirebirdNC » Tue Mar 16, 2021 11:31 am

BtEO wrote: Mon Mar 15, 2021 9:48 pm So my usual trick is to open 'unread posts' then open each post in a new tab, and I'd start to see the errors on maybe the second or third tab. Lately I've been trying to view posts one at a time going back to unread after each one and so far I haven't hit the error under those conditions.

This again leans into some kind of rate-limiting or concurrent connection problem.
I do exactly the same thing and am having the same results.
~Insert clever bon mot here~

Who is online

Users browsing this forum: Common Crawl (Research) and 3 guests